View Single Post
  #1  
Old 10-23-2017, 05:00 PM
Arif Arif is offline
Junior Member
 
Join Date: Oct 2017
Posts: 4
Default Problem : Time, 't', has an invalid value for this interpolation

Hi everyone,

I have a problem with my model in AB. I wanted to add a C3D file to my model so i followed the tutorials and added these lines :
Code:
  InitialConditions.SolverType = KinSolOverDeterminate;
  Kinematics.SolverType = KinSolOverDeterminate;
Code:
AnyIntVar FirstFrame = Main.ModelSetup.C3DFileData.Header.FirstFrameNo; 
  AnyIntVar LastFrame = Main.ModelSetup.C3DFileData.Header.LastFrameNo;
  tStart = FirstFrame/Main.ModelSetup.C3DFileData.Header.VideoFrameRate+2*Kinematics.ApproxVelAccPerturb;
  tEnd = LastFrame/Main.ModelSetup.C3DFileData.Header.VideoFrameRate-2*Kinematics.ApproxVelAccPerturb;
But still, i have the following error :
Quote:
#### Macro command : InverseDynamicAnalysisSequence(8:8)> run
8.0) InverseDynamics (Operation: Main.Studies.InverseDynamicStudy.InverseDynamics):
8.0.0) PreOperation (Operation: Main.Studies.InverseDynamicStudy.InverseDynamics.P reOperation):
8.0.0.0) InitialConditions (Operation: Main.Studies.InverseDynamicStudy.InitialConditions ):
8.0.0.0) ...Design variables have been updated.
8.0.0.1) ...Load-time positions have been re-established.
ERROR(OBJ1) : D:/b..u/D..s/A..o/A..0/AMMR/A..n/E..s/M..l/M..l/JointsAndDriversOptimized.any(12) : JntDriverTrunk : Time, 't', has an invalid value for this interpolation
I apologize for my english and for sending you such a big file, i don't know which file could be useful.
Thanks a lot,

Best regards.
Attached Files
File Type: zip MoCapModel.zip (210.8 KB, 1 views)
Reply With Quote