Forums Anyscript.org  

Go Back   Forums Anyscript.org > Professional Forum > Debug model

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 02-21-2014, 04:28 AM
less8888 less8888 is offline
Junior Member
 
Join Date: Dec 2013
Posts: 25
Default Muscle Recruitment Criterion

Hi,
When I set the inverse dynamic criterion as MinMaxStrict, the following error occurred:
1.0) Inverse dynamic analysis...
ERROR(OBJ.MCH.MUS4) : D:/a..s/AMMR/A..n/E..s/G..y/GaitLowerExtremity.main.any : InverseDynamicStudy.InverseDynamics : Muscle recruitment solver : maximum number of setbacks occured
I 've no idea about this, so how to solve this prooblem?
Many thanks.
Thomas
Reply With Quote
  #2  
Old 02-21-2014, 10:01 AM
danielnolte danielnolte is offline
Senior Member
 
Join Date: Jun 2011
Posts: 198
Default

Hi Thomas,

Which model are you running? Which AMMR/AMS versions do you have?

Have you tried other solvers, e.g. the MinMaxAux? For debugging, you could also increase the order for a polynomial criterion to see how it behaves and if there are also problems showing up.

Best regards,
Daniel
Reply With Quote
  #3  
Old 02-22-2014, 06:07 AM
less8888 less8888 is offline
Junior Member
 
Join Date: Dec 2013
Posts: 25
Default

Hi Daniel,
Thanks for your reply!
My model is GaitLowerExtremity and I changed the C3D data. And the 5.3 version is used.I have tried other solvers and got results.
Best regards,
Thomas
Reply With Quote
Reply

Tags
muscle recruitment

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:25 PM.