Forums Anyscript.org  

Go Back   Forums Anyscript.org > Professional Forum > Debug model

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 12-11-2017, 05:55 AM
bokku01 bokku01 is offline
Junior Member
 
Join Date: Oct 2016
Posts: 23
Default Applying to Helen Hayes marker set

Hi I have in trouble with changing marker set to Helen Hayes marker set with MaCap Model. I am using Anybody ver 7.1.
This is what I have done so far.
1. I changed Anybody program marker name in MarkerProtocol.any as Helen Hayes marker set name.
2. First, I started to change marker name from the marker in the same position of Anybody Marker set and Helen hayes.
3. I adjust the sRelOpt value of some markerset to place the exact position but I am not sure.

I attached the file. Please let me know what is wrong

Thank you

Best Regards
Attached Images
File Type: jpg ??2.JPG (25.2 KB, 5 views)
Attached Files
File Type: zip MocapExamples_rev1.zip (352.7 KB, 10 views)
Reply With Quote
  #2  
Old 12-12-2017, 04:17 PM
pgalibarov's Avatar
pgalibarov pgalibarov is offline
Senior Member
 
Join Date: Oct 2010
Posts: 940
Default

Hi Bokku,

I looked at your model a little. There were some problems with markers and settings. I did some changes to at least move from the kinematic problems, but please have a look yourself. There should be enough kinematic information for each segment for the optimization to go smoothly. Due to the fact that there is less information than needed - sometimes kinematics fails. You could improve this by introducing additional constrains such as removing optimization of the head size, trunk height, etc.

I also had to add additional constraints to foot, otherwise there was strange subtalar eversion. I believe you do not have enough markers as you provided. I did not use additional markers in the C3D. Please add them and see if they help. Please have a look at the LowerExtremity.main.any file to see how I have done that.

Kind regards,
Pavel
Attached Files
File Type: zip LowerExtremity.zip (11.3 KB, 5 views)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:18 PM.