GaitFullBody Model Shoulder starts midway chest

Hello all,

This thread is a product of an other thread: GaitFullBody Model Elbow twists

I’ve captured the motion of people performing tasks with the right arm, such as reaching left & right, pushing and pulling, and many more. For several subjects, the shoulder starts midway chest while the .c3d data does not indicate this error. Also, the elbow twists in other subjects as shown in the previous thread. Perhaps these problems are correlated.

I’ve included the model and .c3d in the .zip file. I’m using AnyBody 5.0 and the AMMVR1.3 version. I do not have the proper subject lengths and weight to include in the subject information.

Thanks in advance,


Hi Hans,

First, I’m very sorry for late reply.

Attached please find a modified version of your model.

What I’ve tried are:

  1. Changed the settings for some markers
  • OptX, OptY, OptZ settings
  • Increased the weight factor of the right elbow marker
  1. Added some very weak soft drivers in SC joints
  • In the ‘ExtraDrivers.any’ file

I hope that this model may be helpful to you.

Best regards,

Hello Moonki,

Thank you for the model. It’s been a while since I got the chance to work on this simulation.

I’ve run the fixed model, but I get an error at Inverse Dynamics step 79:199

ERROR(OBJ1) : C:/U…s/Hans/A…a/L…l/A…y/A…x/A…3/Body/A…n/Arm/Muscle.any : infraspinatus_5.SPLine : Number of allowed iterations for contact solution has been exceeded in Main.Studies.HumanModel.BodyModel.Right.ShoulderArm.Mus.infraspinatus_5.SPLine

Is there a way to loosen these restrictions? Or an other method to adjust upper- and lower arm length (in kinematics optimization) without increasing simulation time from half an hour to for example 3 hours? The problem is, I do not know the body segment lengths exactly, I only have estimations.



Hi Hans,

This error is related to the muscle wrappingm it fails for this particular muscle.

Please see this page concerning trouble shooting on muscle wrapping.

The page mentions an OOSol error, but the error you get is the same type.

I would try first to increase the StringMesh variable of this muscle.

concerning the segment lengths you have two options

[li]Let the optimizer determine the length, by enabling this in the TrialSpecific file [/li][li]Providing a good guess on its length.[/li][/ol]
To make use of option 1 you will need to have enough motion in the data so that the optimizer will be able to determine the lengths.

I hope this answers your question otherwise please write again.

Best regards