hang when anybodycon->step is called

Hi All,

I was wondering if anyone has been able to get a model loaded using the anybodycon command line, then selecting an operation (i.e. Main.Study.Kinematics), and then stepping through the model using the ‘step’ command. When I try to do this, after the first step command call, the program displays multiple lines ending with:

0.0) …Design variables have been updated.

at which point the program seems to hang. I can only exit using ctrl-c.

There is no problem when I use the run command (the model goes to completion). I have also tried putting the step command in a macro file, and I get the same hanging result. I have also tried this on multiple models, most recently the AnyFreePostureMove model in the Examples folder of AMMR_v1.0.

I am the following version:
AnyBody Console Application
AnyBodyCon.exe version : 4. 0. 1. 626
Build : 14365.50040
Copyright © 1999 - 2009 AnyBody Technology A/S

Hi,

Thanks for pointing at it. This will be fixed in version 4.1.

Best regards, Sylvain.