Troubles in adding force plate to the environment

Hello everyone,
I am trying to build a single leg jump land model and currently observing some syntax errors with environment.any(noticed while loading the model)… In my model, I was trying to use force plate type 2 (in folder) but not successful in associating it with the human model… and currently in my model, I have disabled the (environment.any) file and just working with the marker set to drive the kinematics. Has anyone had similar issues or recommend some strategies to troubleshoot this issue.

Inaddition, today I have extracted the muscle forces with out force plate (from the same model) and they are realtively low (As expected). Additionally, in another model built by my predecessor (with same marker set and codes), the environment.any seem to operate however muscle force output is realtively simillar in magnitude…(same as my model output)
So, in conclusion, I have two exact same models on hand where in one model, the ‘environment.any’ works but in the second one, ‘environment.any’ has synaptical errors (can be observed when you run the model). The most intriguing part is from both models, we out put similar magnitude of forces… I am certainly missing some key information here and would appreciate any tips or pointers to resolve this issue.

Thanks
G

Hi,

I was running your model and found some errors. I was not able to fix everything but here are some suggestions. The biggest problem is that the Fz is positiv in your case and usually negative! So you have to check the directions everywhere.

In order to load it, I had to outcomment that in the modForcePlate.any:
// AnyFloat Origins= Folder.Groups.FORCE_PLATFORM.ORIGIN.Data;

I think you have to change the minus in
AnyVar OnOff=iffun(gtfun(-FzTotal,10.0),1.0,0.0);
into
AnyVar OnOff=iffun(gtfun(FzTotal,10.0),1.0,0.0);

but there will be more changes. I would suggest to run the model without muscles and then look at the forces to see in what direction they go.

I hope that helps, or at least point you in the correct direction.


Hi Amir,
Thanks for the reply, yes I was successful in solving the issues with “environment.any”. I did realise that there is something wrong with the forceplate co-ordinate orientation or system last evening, today I will be looking at it again and try to resolve it.
Meanwhile, I did notice some issues regarding my marker locations as well so I will have to review them again.

Thanks
Gajendra (G)

Hello,
I have tried fixing the model to make the force plate working, although I donot see any real errors while loading the model or creating out put of muscle forces, I am certain that forces are not being applied while landing.
As Amir suggested, I have tried orienting the forceplate coordinate system so that it is point towards the ground and not sure if it is right either…
I am not even sure where to being with and wondering if there are errors with my C3D file as such… I am trying to debug it for 2 days without much success, can anyone recommend any avenues to debug the model…
attached is the latest version of my model with forceplate coordinate in the required orientation!
Thanks
Gajendra [SIZE=3]
[/SIZE]

Hi,

first, in you model you outcommented:
//Main.Studies.KinematicStudyForParameterIdentification.InitialConditions.KinematicTol=1e-3;
//Main.Studies.KinematicStudyForParameterIdentification.Kinematics.KinematicTol=1e-3;

you have to change that again into:
Main.Studies.KinematicStudyForParameterIdentification.InitialConditions.KinematicTol=1e-3;
Main.Studies.KinematicStudyForParameterIdentification.Kinematics.KinematicTol=1e-3;

additional I changed the following sequence in the ForcePlatform:

AnyForce3D Force ={
AnyRefFrame &ref=.ForcePlate.TransducerLocation ;
Flocal={.load(.ForcePlateDriver.t)[5],.load(.ForcePlateDriver.t)[4],.load(.ForcePlateDriver.t)[3]};
// Flocal=.OnOff*{.load(.ForcePlateDriver.t)[5],.load(.ForcePlateDriver.t)[4],.load(.ForcePlateDriver.t)[3]};
AnyDrawVector DrawForce = {
AnyRefFrame &ref=.ref;
Vec=.Flocal1/1000;
PointAway = Off;
DrawCoord = Off;
Line.RGB ={0,0,1};
Line.Thickness = 0.01;
Line.End.Thickness = 2
0.01;
Line.End.Length = 4*0.01;
GlobalCoord=Off;
};

it was running here on my PC with about5time bodyweight which seem ok, hope it will work for you as well…

Thank you Amir,
For now the model seems to work… I appreciate your efforts with this…
I had a quick question regarding the graphics on the model, looks like I have blue streak (line seen in the model view) that stretches horizontally in the model view, is there an explanation for that or it is something graphical and not an error in my codes.
I would like to understand the relevance of it as it does not look alright.

Thank you for the help
Gajendra

Hi Gejandra,

yes, you are right, that is not correct. The blue line that you see there is the force apllied to the ForcePlate and the Force of the COP. There are two possible errors, either the Force is applied in the wrong coordinate system, or the force is drawn in the wrong coordinate system.

I had a quick look at the model, but couldn’t find anything. I guess you are more familiar with your model and will find something more easily.

Hi Amir,
Yes I realized that I had issues with my code and the CD3 file… now working on it.
Thanks for the prompt reply, it re confirmed my doubts…
I appreciate it!
G

Hello,
As noticed in previous posting, I had issues with forces acting in wrong direction. However, I have fixed that issue by aligning my force plate coordinates to correct direction of forces. However, I am not sure why I am seeing an additional blue line (acting from above force plate) beside the foot (As seen in wroking model). I understand that the blue line from underneath the foot is the GRF, not sure what is the other line! I am assuming that it is contributing to additional working of muscles. any suggestion regards to this please!

Thanks
Gajendra

Hi,

you have at the end of the ForcePlateType2.any a Vector defined:

AnyFolder CenterOfPressure ={

  AnyDrawLine Line = 

if you out-comment this it will disappear. It does not look like it is used for any Force.

Hi Amir,
Thanks for the reply, yes I did comment out another line in the force plate.any and it worked out well and you are right about it not being a force vector, the line was indicating the tranducer location on the force plate… So, it is all good now thanks a lot for help…

Regards
G