Hi all!
I am trying to work with the AnyInputC3D but it isn’t as easy as I hoped before.
So I have to ask if there is any tutorial or example of working with this new feature.
Thanks for your answer.

Hi Anja,

There is unfortunately no tutorial available yet. Can explain what kind of problems you are having? Then perhaps we can help you?


Ok, I will try to explain my problems to you.
I included the c3d-File to anybody and outcommended everything around the anyinputc3d so that only the markerpoints are visible.
Then I made the KinematicAnalysis and the points walked in the screen like ants, and that was definitively not the motion from c3d.
So I looked at the coordinates and found out that e.g. anybody had the coordinate -843.xx and the c3d-File -0,8444…
So I wondered about that and now I am not sure if this is right.
I hope you understand what I mean :wink:
And I am very interested about your answer.

Hi Anja,
It sounds like a millimeter to meter conversion problem. We make AnyBody models in meters while many motion capture systems record positions in millimeters. To account for this you can set the

[SIZE=3]PointsScaleFactor = 0.001;[/SIZE]
[SIZE=3][COLOR=#000000]If this does not help, please upload the model.

Thank you very much, this was a very helpful tip and now the coordinates from c3d and anybody looks like the same.

Dear AnyBody Communitiy,

I have a new question about the AnyInputC3D.
I included my file now and it works very well if there are only the points visible.
Bu now I want to make my Model walk but I get a Kinemtic error for the InitialCondition and the Kinematics.
I tried working with the filter but a good result wasn’t found.
Maybe you can help me wth this problem, too.

Dear sincerely, Anja.

Hi Anja,

Importing the markers with the AnyInputC3D is actually the easy part. The difficulties begin at the moment to hook up the body with the markers.
I can’t help you much without knowing how far you are in this process. You know there are two ways to go, the GaitApplication2 or the manual method. Which one are you trying?

There can be a lot reason for the kinematic to fail, so if you can give us more details it will be easier to help you.

In a general way you can find a description of how to use the gait application in the main file of the GaitUniMiami model, and a description of how to go with the manual method in the wiki page of

Best regards, Sylvain.

I tried it about the drivers with the [SIZE=3][SIZE=2][COLOR=black]AnyKinEqInterPolDriver and the AnyKinLinear. There I connected the Markerpoints with the Segmentpoints.

Hi Anja,

This is quite a short description. So i understand you are using the manual method to connect the markers to the body.
In this case i really think you should refer to the description on the wiki:

There you will find all the detailed indications to go throuh the kinematic process. Please read it carefully. If that doesn’t help you then please write a more detailed description of your problem.

Best regards, Sylvain.

Thank you for your tipp.
Now it works.