c3d file ERR

i’m first step in anybody student…

I think that my c3d file have a problem

attached ERR message(Run GaitLowerExtremity), c3dfile,
and I want About what kind of role the display part(Red line) of the picture file


Model parameter optimization option =1
Inverse dynamic= 0
run motionandparameteropimization Run <<<<<<<<< ERR

please help me


I’m testing your C3D file in the latest AMS V5.3 and AMMR V1.5.1.
In this version there is no problem in loading your C3D file.

So I would strongly recommend you to update your AnyBody software as latest version.

By the way, we could find some problems about the force plate data in your C3D file.

Which manufacturer of force plate system did you use for this C3D file?

Best regards,


Attached please find a test model and the snapshot of that model.

This model is created based on AMS V5.3 and AMMR V1.5.1.

In terms of ‘Kinematics’, this model will work.

But the problem is that the information about force plate in your C3D file is wrong.

As you can see the attached snapshot file, the sequence of corner points seems wrong.

You can find more detail information about the specification of C3D file here:

I would recommend you to contact to your force plate manufacturer about how they create its C3D file.

Best regards,


Thanks to you
I can next step thanks for your adjustment

//Another problem occurred
//(my test file frame have 200 frame but AMS output is 10~20 frame ,
//I performed 2step gait but AMS data have first one step(half))
//solved this problem

In addition I would like to know the difference between the sent filefolder(GaitLowerExtremity_KKU) and original filefolder(GaitLowerExtremity)

and you pointed out, forceplate is reverse mean? or other problem?


  1. The main differences are ‘ModelSetup.any’ and ‘ExtraDrivers.any’ files.
    Because you didn’t use enough markers in the upper body, you should modify ‘ModelSetup.any’ file. You can check it in the first capture file.
    And also because there is not enough information in your C3D about how to drive the upper body, so in the ‘ExtraDrivers.any’ file you should use some drivers for Pelvis-Thorax rotations.

  2. If you can see the second capture file, you can see that the local coordinate system of your force plate is flipped.
    If you can see the following information about C3D file for force plate, then the local Z axis of the force plate coordinate system should go into the ground.
    But in your C3D file, the direction of Z axis is wrong.
    You should ask to your lab technical support about how you can generate the correct C3D file, maybe Motion Analysis Corp…
    If you want to use AnyBody with your laboratory environment, you should correct this problem as soon as possible.

Best regards,


attached to another file
z axis was inverted(using cortex program)

I’m following the end of the experiment
Are Changing the file from the cortex program?

Did I understand your description correctly?

I am always grateful for your answers

change c3d file TT >> TT4

change TT4 FP axis changed as basic c3d file


It seems that you could change the coordinate system of force plate correctly.

But when I look the COP and force, then still it seems wrong.
COP should be under the foot.

You can download this software MOKKA and open your C3D file.

Please contact to your force plate technical support or motion capture software provider to solve this problem.

Best regards,


here is my c3d file, i have problems load it in GaitFullBody. Thank you for your answer and for your another help.



When I looked your C3D file very quickly, there are two problems.

  1. The RTHI marker in your C3D file is almost dropped-out.
    This may the reason of the kinematic error.

  2. Both left and right feet are on the same single force plate.
    Of course this second issue is not related to the kinematics.
    But if you want to perform the inverse dynamics, then I would recommend you to use one more force plate.

If you still can’t figure out how to solve your problem, then please upload your full AnyBody model here as a zip compressed file.

Best regards,


I’m the beginner in the use of AnyBody. It would be great if you could help me. I have some problems with C3D file too. Please, find enclosed file. I would like to use this data for GaitFullBody model. When I load it I get this error message:

ERROR(SCR.PRS9) : D:/U…s/L…a/r…y/A…x/A…o/A…n/E…s/G…y/ModelSetup.any : Defined At : D:/U…s/L…a/r…y/A…x/A…o/Body/A…n/T…x/M…p/CreateMarkerClassTD.any : ‘PosInterpol’ : Unresolved object

I tried to compare the marker names in AnyBody and used in C3D files. Two of them weren’t the same. Thus I changed the names in ModelSetup.any. Nevertheless it didn’t help…

Thank you very much,

Hi Linda,

Could you please upload a zip file which contains your AnyBody model?
And could you start a new thread in this section?

Also let us know which version of AMS and AMMR you are using.

Best regards,