error in parameter optimazation AnyBody 5.2

I am using parameter optimization functionality, but not with the built examples (GaitLowerExtremity etc)
I can load and run the kinematics but when I am trying to run the kinematic optimization I get that error message:

[FONT=&quot]#### Macro command : Run_Kinematic_Optimization(2:3)> run[/FONT]
[FONT=&quot]2.0.0) Operation Sequence: (Operation: Main.JntParameterOptModel.OptimizeParameters.Analysis): [/FONT]
[FONT=&quot] Kinematics (Operation: Main.JntParameterOptModel.OptimizeParameters.KinematicStudyForParameterOptimization.Kinematics): [/FONT]
[FONT=&quot] PreOperation (Operation: Main.JntParameterOptModel.OptimizeParameters.KinematicStudyForParameterOptimization.Kinematics.PreOperation): [/FONT]
[FONT=&quot] InitialConditions (Operation: Main.JntParameterOptModel.OptimizeParameters.KinematicStudyForParameterOptimization.InitialConditions): [/FONT]
[FONT=&quot] …Design variables have been updated.[/FONT]
[FONT=&quot] …Load-time positions have been re-established.[/FONT]
[FONT=&quot] …Kinematic analysis completed. The kinematic constraints have been resolved.[/FONT]
[FONT=&quot] …Initial conditions are fully updated.[/FONT]
[FONT=&quot] Kinematic analysis…[/FONT]
[FONT=&quot] …Kinematic analysis completed[/FONT]
[FONT=&quot]2.0) Optimization (Operation: Main.JntParameterOptModel.OptimizeParameters.ParameterOptimization): [/FONT]
[FONT=&quot]2.0) Optimization step (Operation: Main.JntParameterOptModel.OptimizeParameters.ParameterOptimization): [/FONT]
[FONT=&quot]2.0) Evaluating KKT conditions (Operation: Main.JntParameterOptModel.OptimizeParameters.ParameterOptimization): [/FONT]
[FONT=&quot]ERROR(OBJ1) : C:/U…s/ith/D…s/G…b/L…g/K…l/ModelSetup.any : DynamicDataSet.Points.Markers.RMKnee.PosInterpol : Parameter has an invalid value for this interpolation; extrapolations are not allowed.[/FONT]

It has nothing to do with the tStart/tEnd values of the study. I have spoken with Michael Skipper Andersen‎ and he ensured me that it is a bug in AMS it self. I have been told that the bug is not present in the console application, but in AnyBody 5.2 I get the following error when loading a model with console.

[FONT=&quot]>load “Kinematics.main.any”[/FONT]
[FONT=&quot]Loading Main : “C:\Users\ith\Documents\GitHub\LowerExtremity-RBF-scaling\Subj[/FONT]
[FONT=&quot]ERROR(SCR.SCN9) : System and load argument definitions (Virtual File)(8) :[/FONT]
[FONT=&quot]‘System and load argument definitions (Virtual File).2\anybodycon’ : Path does n[/FONT]
[FONT=&quot]ot exist.[/FONT]
[FONT=&quot]Model loading skipped[/FONT]

So there is really no work-around for me. Can you help me fix this problem.


Hi Ilias,

Could you upload your model so we can replicate your error message. And please provide AMS and AMMR NR.

Hi Amir,

Thanks for your reply.
You can find my model here:
I am using AnyBody 5.2 with AMMR1.5.

Thanks in advance,


sorry, I deleted the link with your link, because I was told that you may have a model that is not open for the public.

Problem 1 interpolation/extrapolation: Yes, this is not your fault, but I’m not sure if it is a AMS bug. I have seen this many times before, but if you change tEnd and tStart the model loads fine again:

I changed -1 into -10 and it worked
AnyIntVar LastFrame = Main.ModelSetup.DynamicDataSet.Header.LastFrameNo-10;
AnyIntVar FirstFrame = Main.ModelSetup.DynamicDataSet.Header.FirstFrameNo+1;

It looks like something is going wrong in the end of the model. I’m not convinced that this is a AMS problem, it might be something C3D related… But we will look into that.

Problem 2 Console: The model loads smooth on my machine, but one of the developers had seen something similar before and is looking into that now. It might be something simple, eg a " …
… " in the script of a path description is seen as a new line command. Development is aware and working on this issue.

One more comment:

do you use

AnyBody version : 5. 2. 0. 3070


Hi Amir,

thanks for your reply.
Yes I am using that version of AnyBody (5. 2. 0. 3070).

I did what you suggested,but I still get the same error message!!
So, I am looking forward to any new suggestions.


Hi Amir and Ilias

I have the same problems with the new version of AMS. The kinematics works fine, but I get an interpolation error when parameter-optimization starts.

No selection of the start/end times have solved my problem. However, I had no problems running the model in the console application. So that was my work-around.

Like Ilias’ case it doesn’t happen when I run the AMMR example models. However, I believe Ilias is still right, it looks like a bug in AMS, since it wasn’t a problem in the previous version, and since it still works with the console application.

Hope you solve the problem,