Error when loading model in Version 5.1


I just tried to load a model that had been running in version 5.0 and got the following error:

Converting ANYSURF file to newer format/extension. File ‘E:\AnyBody_Monique\TwoBones\Elizabeth\Scapula_new.anysurf’ to ANYSURF file ‘’
ERROR(OBJ.FILE1) : E:/AnyBod…onique/T…s/E…h/ScapulaSegAB.any : DrwSurf.FileName : Problem with file : E:\AnyBody_Monique\TwoBones\Elizabeth\Scapula_new.anysurf : Error while saving ANYSURF file.
Model loading skipped

Can you please tell me how we can solve this problem?

The Scapula_new.anysurf was from the repository available with version 5.0 - is it just a case of finding a new version of this in a new repository or if not how can the file be converted?



Hello Monique,

That error message looks a little strange to us, so I would like to explain something you might already have realized:

AMSv5.1 does not use “xxx.anysurf” files, but “xxx.anysurf3” files. When you load your model the first times, AMS creates the “xxx.anysurf3” out of a stl or original “xxx.anysurf”. It looks like something went wrong during this process in your case.
My question now:
Do you have other anysurf3 files in your body repository?

If the scapula is the only bone that did not transfer from anysurf to anysurf3, then there is one attached (scapula_new.anysurf3) to this post.


I removed the old scapula file and replaced it with the one in the zip file. I also changed the name in the file that called the scapula file (ScapulaSegAB) to have the new name.

However, I still get the following error:

Loading Main : “E:\AnyBody_Monique\TwoBones\Monique_Nov\TwoBonesAB.any”
Constructing model tree…
Linking identifiers…
Evaluating constants…
Configuring model…
Converting ANYSURF file to newer format/extension. File ‘E:\AnyBody_Monique\TwoBones\Monique_Nov\Scapula_new.anysurf3’ to ANYSURF file ‘’
[SIZE=1]ERROR(OBJ.FILE1)[/SIZE] : [SIZE=1]E:/AnyBod…onique/T…s/M…v/ScapulaSegAB.any[/SIZE] : [SIZE=1]DrwSurf.FileName[/SIZE] : Problem with file : [SIZE=1]E:\AnyBody_Monique\TwoBones\Monique_Nov\Scapula_new.anysurf3[/SIZE] : Error while saving ANYSURF file.
Model loading skipped

This error refers to the new scapula file. I also have a humerus in the model but as yet have not had any errors for that bone.

This is causing a lot of trouble as I can no longer work on this model. Do you have any other suggestions?



Hello Monique,

  1. Do you have rights to write in the folder? Is the folder protected?

  2. Do you have other anysurf3 files in the folder?

please send me the files, so I can have a look at it.


I have checked and I do have the rights to write in the folder.

There are just two surfaces - both were anysurf files. The problem has occurred with the scapula which I have replaced with your anysurf3 file which did not seem to help. The humerus is generated after the scapula and as it crashes at the scapula I am not sure if this surface will also cause problems.

I have attached a zip folder with all the files inside it.

Thanks for the help



try it without the .anysurf3 command:

AnyDrawSurf DrwSurf =
FileName = “Scapula_new”;
RGB = Main.DrawSettings.Colors.Segments;
ScaleXYZ = {1, 1, 1};
Opacity = Main.DrawSettings.BonesOpacity.RightScapula;

then it loads smooth.

Change it also for the humerus. I will talk tomorrow to the development guys to see if this is meant to be so :confused: