Error when reopen file ( from the template) that are saved to my own folder

Hi, I am new to anybody modeling system, currently on a trial version 7.2.3 of it. The problem I encounter is that every time I saved a modified file (originally from the template) to somewhere else, after that the next time I try to reopen it, it shows an error when loading the file, the error says :
ERROR(SCR.SCN1) : C:/U..s/X..A/D..s/A..x/A..o/Q..r/StandingModel.Main.any(1) : Cannot open file : C:\Users\XINGA\Documents\AnyBody.7.2.x\AMMR.v2.2.1-Demo\Qiaoqiao Zhu Folder\libdef.any
Can anyone help me to resolve this issue? Thanks!


Just copy the libdef.any file (can be found in every single folder in AMMR-demo folder) into your folder.



The model should look up to an existing libdef.any, but in your case you introduce a new level "Qiaoqiao Zhu Folder", which breaks the relative path, and you get an error.

To fix this you can either add ../ to the line in StandingModel.main.any, which includes libdef.any or use an absolute path instead like this:

#include "C:\Users\XINGA\Documents\AnyBody.7.2.x\AMMR.v2.2.1-Demo\libdef.any"

Kind regards,

Hi Nickel, thanks for the suggestion, somehow it did not work, but you inspired me, it is successfully loaded now after I copied the whole files in the demo folder (including the libdef file, the three subfolders named 'Input', 'Model', and 'Output') to my folder. Thanks a lot.

Thanks Pavel, thanks for showing me the reason for this error, and for the suggested solution, I tried both, but somehow it did not work well. But I tried copying the whole files in the demo example folder to my folder, and it works. thanks very much.

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.