How to use text data

Hi AnyBody support,

I want to run inverse dynamics to use c3d data.
I try to opened c3d data to use AnyBody and mokka. But I can’t open c3d data.
SO, I run inverse dynamics to use text data because my c3d data has bug?
Please tell me using text data.

I attach c3d contained bug.
Plese check this data.


I also tried to open your C3D file in both MOKKA and AnyBody, but I could not do that.
It seems that there are some problems in your C3D file.

So, I would suggest you to look ‘GiatUniMiamiTD’ and ‘GaitVaughan’ models.

Best regards,

Thank you for message.

The c3d file is entering and exiting motions of automobile.
Would it be possible for you to handle this?

I use makers position that is plug-in-gait.
So, I want to use ModelSetup’s information.


As I told, I can’t open your C3D file.

What kind of motion capture system are you using?

Can you create a new C3D file from your motion capture system again?

Best regards,

I use japanese motion capture system.
Although I used other file, I receive same error message.
So, I use text file.


What kinds of other file format can you generate from your japanese motion capture system except C3D?

Best regards,

Thank you for message.

This soft can generates csv and avi file.


Then, please upload CSV file.

Do you have any other file which contains force plate data?

Best regards,

Thank you for message.

I attach CSV file.
This files makers name don’t be changed.

No, I don’t have file contains force plate data.


I think that it will be better for you to practice ‘GaitUniMiamiTD’ model in the example folder of AMMR.

Because you can’t generate C3D file from your motion capture system, you have to use your CSV file which contains the global trajectory of markers.

If you see ‘ModelSetup.any’ file, you can see how this model tries to replicate C3D structure with some raw data.

It will take some time for you to finish this model, but because you can’t use C3D file, this is the easiest way for you.

Best regards,

Thank you for message.

Sorry, I can’t understand this model.
Should I use C3DData file?

Also,I attach a model.
I want to use the model.
This model is graduate’s model.
He use text file and run inverse dynamics.

Should I use GaitUniMiamiTD or this model?

I challenge to change the model .
But, I receive error message.
The message is ERROR(OBJ.FILE1) : C:/U…s/h…9/D…p/a/A…5/A…5/A…n/E…s/C…l/FilterandMocapDrivers1120.any : DataIn.FileName : Problem with file : C:\Users\haselab39\Desktop\a\AMMRV1.5\AMMRV1.5\Application\Examples\Coment_model\1.1_01_01Freposi.csv(2) : There appears to be no data point values in the first line containing data, only the parameter value was found.
This file is markers data .
I don’t understand error reason.
AMS is 1.5.

Dear Sakurai,

I don’t think that it is possible to use the data from the csv file. Do you know what is in the file? Do you understand the structure of the csv?

I think you need to use the GaitUniMiami and change the marker coordinates with the ones you have.

Thanks you for message.
This file is entering and exiting the seat of automobile.
Marker set is plug-in-gait.

I challenge to use GaitUniMiami too.
Sorry, I don’t use text file.

I change csv file and read main file.
AnyBody displays Evaluating constants…
but AnyBody doesn’t display next information.
I can’t find reason.


I’m trying to figure out the csv files which you’ve uploaded here before.

In your csv files, there are 41 markers from P1 to P41.

But from these points, it is hard to guess the definitions of markers.

If you see the following video for the plug-in gait marker set of VICON motion capture system, we can distinguish the markers by special names.

But in your csv file, because all marker names are such as P1 and P2, it is very hard for us to find where they are attached.

It seems that you are using Venus3D motion capture system. Do you have any manual for that system? Then it would be helpful for us.

Best regards,

Thanks you for message.
Sorry, I study this model.


It seems that you are using Venus3D software to get your CSV data.

And when I see the post of another user who uses Venus3D, it seems that Venus3D can generate C3D files:

Are you sure that you can’t generate C3D file from Venus3D system??

Best regards,

Thanks you message.
I can use c3d file by c3deditor.
Thanks you.

But I receive error message of ERROR(OBJ.MCH.KIN3) : C:/U…s/h…9/D…p/a/A…5/A…5/A…n/E…s/G…y/GaitFullBody1101.main.any : MotionOptimization.InitialConditions : Kinematic analysis failed in time step 0

AMMRV is 1.5 , AMS is 1.5.
I beg your kindness.


In your ‘’ file, there is one C3D file, ‘1.1_01_01Frepos.c3d’.

And there is one CSV file, ‘02_02_04Brename.csv’ file.

So can you generate C3D files always from your system? Are you sure??

Best regards,