MoCap Model - Error when usid 3E Muscles

Dear AnyBody Team,

I am using AnyBody 6. 0. 4. 4327 and AMMR 1.6.2.

I changed the simple muscles to 3E muscles. The calibration seems to run, but I always get the same error:

ERROR(OBJ.MCH.MUS4) : C:/U…s/a…r/D…s/A…k/0…y/A…o/A…n/M…s/M…e/M…l/InverseDynamics.any(29) : InverseDynamicStudy.InverseDynamics : Muscle recruitment solver : solver aborted after maximum number of iterations

I have tried it with ten different trials, always getting the same error. I recently had to reformat my notebook and reinstall AnyBody. Before I did so, every time I changed from simple to hill type muscles it worked without any problems. However, I do not know on which trials I tried the hill type muscles before.
I do not know where to look at next and what to change and would appreciate your help!


Hi Nathalie,
I don’t have your corner FP class templates, so I excluded them. The model runs without the force plates. Is something wrong the way you setup those force plates?

Hi Amir,

I have attached the FP corner file (sorry for missing that one).

I have used this FP setup in previous analysis and joint moments, compared to another inverse dynamic model, were similar.

However, maybe I have made a mistake that plays a great role concerning the muscles, but not the joint moments…

I think you are not using the AutoDetection in this model. :smiley: :confused:

ah I am sorry, I selected the wrong file… :rolleyes:

:confused: it runs until the end on my machine!?!

when using the Hill type muscles?
it runs perfectly with the simple muscles, but with the 3E I always get the mentioned error…

strange… could there be an issue with the version? I am using 6.0.4 and not the latest version?

yes, I have the 3E muscles and it solves. I don’t think it’s because of the AMS, but more because of the AMMR. Can you install a fresh AMMR (the latest) and check again.

thanks, now it solves!