Muscle recruitment solver Error


I'm using the Lower Extremity model from the MOCAP Examples Repository. When I run the Inverse Dynamics I encounter immediately the following error: " Muscle recruitment solver: solver aborted after maximum number of line-search iterations". I've tried changing markers and using different c3d files but I still get the same error. I tried making the changes suggested in the forum but it didn't work either. I tried running the analysis using the GRF prediction and in this case Inverse Dynamics runs, so the problem could be with the Force Plates as Anybody also returns the following error: " material.RGB : RGB value is out of range : Values are corrected from {-nan, -nan, -nan} to {1, 1, 1}". It's very strange because I'm using the same model that other people in my lab used, so we had the same system of data acquisition and force plates, even the same marker set, but they didn't have this error. Do you have any suggestions?

Hi Camillantognini,

From the hints that you provide, it could be that force plate is not detecting contact with the human model. You could check that if you run MarkerTracking study and look for the EnvironmentModel.ForcePlates.Plate1.InContactOnOff output in the chart.

Another point to check is if your model has the HumanGroundResiduals set up? You can find this in the model tree: Main.Studies.InverseDynamicStudy.ModelEnvironmentConnection.HumanGroundResiduals. Normally, the human ground residuals should take care of the unbalanced forces in the model.

Lastly, I could suggest you to double check the c3d files in another program, look at the force numbers and ensure that they are sensible for the activity. it can happen that maybe some settings were changed during the recording or exporting of the c3d file and the numbers are not what they normally should be.

Best regards,

Hi Dave,

Thank you for all the suggestions. I checked both the human ground residuals and the force plate contact but it all seems set. Should I change some settings in the human ground residuals?
I checked the c3d file on Mokka and the forces were exported well, the only thing out of place seems to be the force plate color. The data I'm using were collected with Qualisys, when I import the file in Anybody it says the force plate type is 4, the color is automatically set to "-nan", that's why it returns the fatal error "RGB value is out of range : Values are corrected from {-nan, -nan, -nan} to {1, 1, 1}", so I don't know if this could be one of the issues. I noticed that when I run both Parameter Identification and Marker Traking the force plates change colors from grey to black, which seems weird as I looked at similar models from past projects and this doesn't happen. Do you have any suggestions on how I could resolve the force plate color issue?
I also tried removing some markers to see if they were preventing the inverse dynamics analysis from running, but it doesn't look to be the issue, also because I'm using a standard lower body marker set.

Kind regards,

Hi Camilla,

Have you checked if the force plate type is set correctly in the file "Setup\ForcePlates.any"? It could be that the type value used in this c3d file is different from what has been specified in "Setup\ForcePlates.any", which defines the parameters for applying GRF in Main.EnvironmentModel.ForcePlates.

Since you get a warning about the force plate type, this might be it. Also, it can explain why you are getting messages regarding the RGB values. The RGB values takes into account a few factors such as if the foot is in contact, the maximum force value in the file (for color scaling) and if the force plate is on or off (if there is actually a force at the current time step). You can check the force plate type in your c3d file if you explore it in the model tree: Main.ModelSetup.C3DFileData.Groups.FORCE_PLATFORM.TYPE.Data.

Hope this helps.

Best regards,

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.