Overloaded muscle configuration of PsoasMajor


I am doing research with hospital about scelosis surgery.
We made more than 40 model using motion capture data from 40 people.

But more than 10 model has a same problem in the same muscle. PsoasMajor.

marker is really close as below figure.

I think it's not a user problem but solver problem. Can you help?

Hi Javis,

I think the issues is likely the spine not having muscles enabled.

When the spine is running without the muscles instead it add joint torques generators in the lumbar joints, these are possibly not strong enough.

Since you have no muscles in the spine i assume that you are not interested in spinal forces, so you could simply add an AnyReacForce to all the lumbar joints, then I think the overloading of psoas will go away.

Best regards

Really really thanks. Now I know the reason why...
So I changed the model to full body. but I don't have arm marker.
Is there a way to remove only arm in the full body model??

Hi Javis,

You do not need to enable the arms, you can control the configuration of the model using the BM statements see

Configuring the Body Model — AMMR v2.4.2 Documentation (anyscript.org)

I would switch back to the lower extremity model and just enable the spine muscles (or add the reactions as i suggested)

If you go to Labspecific.any file you will find the file BodyModelConfig.any being included. In this file the different BM is set and you can enable the trunk muscles alone.

Best regards

Thanks...you saved me
I modified my model as your insruction and it worked

super, thanks for the feedback

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.