Plug-in-gait model "No Class Information" error

kinematics
#1

Hello,

When I load the C3D file to determine the marker positions of static position, there came the error below:

Macro command : KinematicView(1:1)> classoperation Main.ModelSetup.Views.KinematicView"Set View"

ERROR(SYS1) : Operation : Unknown error : ‘No Class Information’

What should I do to deal with this error?
Any help would be appreciated.
Thank you!

#2

Does this happen with the default examples in the AMMR. Could I maybe reproduce the error my self? I thing this may be some kind of bug you have stumbled upon.

I have sometimes seen error similar when the previous operation had failed. Was that the case here?

#3

Hello,

It didn’t show this error with the default examples in the AMMR, It showed when I loaded the sixth grand competition static C3D file and ran the Parameter Identification. Normally even if I didn’t place the markers in the right positions, they would just show the information: Kinematic analysis failed in time step 0 : Indefinite positions. This is the first time I’ve seen this error.

Thank you!

#4

I think the ERROR(SYS1) : Operation : Unknown error : ‘No Class Information’ may have been triggered by the kinematic error you got prior to that.

The error:
Kinematic analysis failed in time step 0 : Indefinite positions.
indicate that some drivers are missing. I would guess that the new C3D file has a different marker configuration, so some degrees of freedom are not constraints.

In the newer versions of the AMMR I would usually try to add soft kinematic drivers using the I usually use the BM_MANNEQUIN drivers. Look in the “ExtraDrivers.any” file in the MoCap examples.

In older version of the AMMR you need to manually add drivers to constrain the DOFs for which the motion is not specified by markers.

#5

I’ll try it later.
Thank you!

BW!