Problem with loading c3d

Hi, EveryBody!
I need to load c3d file to AB (attached file P0001.c3d), but it doesn’t load markers properly. I can’t see them in Model View window. I’ve tried different values of PointsScaleFactor no results. I’ve turned WriteMarkerDataToFilesOnOff = On to see if AB dumps data to txt files, but it does not! :frowning:
For example file norm8.c3d loads properly(only needs to make PointScaleFactor = 0.001). May be I’m doing something wrong or c3d file is corrupted.
Here’s the code for c3d input i use:

[SIZE=3]AnyInputC3D[/SIZE] P0001 =
FileName = “P0001.c3d”;
PointsScaleFactor = 1;
WriteMarkerDataToFilesOnOff = On;
MarkerScaleXYZ = {1, 1, 1};
MarkerRGB = {0,0,1};
MarkerDrawOnOff = On;
MarkerInterPolType = Bspline;
MarkerBsplineOrder = 8;

AB says that the model loaded and no errors occured.

I have not actually loaded your file, but I am working on a tutorial about mocap data import at the moment, so here’s my best bet:
A C3D file contains two data sections: one for raw data and one for processed data. The problem mgiht be that your C3D file has its data in the processed data section.
By default, AnyBody creates markers based on raw data, but if your C3D file has been processed by other software prior to being read by AnyBody, then the other software may have moved the marker data to the processed section leaving you with nothing in your model.
The remedy is to set
MarkerUseAllPointsOnOff = On;
which instructs AnyBody to read data from both the raw and the processed data sections.
I hope that helps. Otherwise, please post again.

Hi, John!
Thank you very much! It worked!:cool:
One more question, when are you planing to make a release of mocap tutorial?

The tutorial comes out with the beta release of version 4.1. I am hoping for any day now :-). It should not take long.