Trying to run opencap-core locally on my pc, but can't get to run

Hi, I've been following this page to install opencap-core onto my pc to test it out: GitHub - stanfordnmbl/opencap-core: Main OpenCap processing pipeline

I've got through the installation process, followed every step fine, and am now stuck at first step of 'Running the pipeline'.

When I run I get the error "No module named 'decouple'". I've checked, and python-decouple is in requirements.txt, and is installed on my laptop. I've noted that decouple can be an issue, and have tried running the script with it and without it, and neither have worked. I've added the paths to my environment variables so they should be accessible.

Can anyone help? I don't know why it's complaining about not having a module I'm pretty certain it does have. I must be doing something wrong, but can't see it. Any help would be appreciated. Thanks!

Hey Alex,

I think you posted this in the wrong forum. I think you meant to post it here


This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.