URGENT: Kinematic Analysis Failed in Time Step 0 - "above error tolerance"


I followed a tutorial to simulate basic sit to stand motions for a subject and was able to generate the desired simulation. Later, I imported Solidworks structures to the model view. The structure is that of a seat (there are four different structures of four different angles). When I loaded the subject and the structures in the Model View, there was a great distance between the two so I altered the initial position values for the structure and changed the subject’s characteristics to better reflect the actual positioning of a human subject in the lab. Upon running the simulation, I am greeted with an error, (“ERROR(OBJ.MCH.KIN3) Kinematic Analysis Failed in Time Step 0”

How can I import the Solidworks assembly into the Model View and insure that the subject will interact with it? Before the assembly was introduced the subject was able to undergo the simulation. Is there a way to simply move the subject’s position without altering the calibrated change of angles for the sit to stand motion? Please let me know!



Sorry for the slow reply, it is caused by Eastern.

I have looked at the model, here are my findings:

[li] The Solidworks model looks ok, it seems to have one segment and six constraints.
[/li][li] It is unclear to me how you model is driven, since i can not see the JointsAndDrivers.any file
[/li][li] Which model/tutorial did you start out with?
[/li][li] Very often the model use the values in the mannequin.any file for two things, set the initial position of the body and for driving the model.
[/li][li] From your description i understand that the model was moving ok, then you changed values in the mannequin file to change its position to be closer to the “box” and then it no longer worked.
[/li][li] This could be because the feet may be connected to a specific point on the floor in the JointsAndDrivers.any file? … maybe this points needs now to be altered.

Best regards

Hello Soren,

Thank you for the guidance! I will look towards the JointsAndDrivers file.

Attached is a copy of the handout tutorial that I followed.

I checked the JointsAndDrivers file and there are no points specified. The only addition to this tutorial that I have featured are the attachment of the Solidworks box.




In the JointAndDrivers.any file there are two include files one for the left and right foot.

In this file there is a connection defined to the globalref in {0,0,0}

There is also a balance driver… controlling the center of mass to be above 0,0.

Both these drivers could possible be in conflict with the location of your box. If the box is far away from 0,0 and you have moved the model to this location it will attempt to move it to 0,0 when it solves for the first timeframe.

Hope it made sense

Best regards

On the Mannequin folder, I orient the subject accordingly as per the Posture and that is what is displayed in the Model View. I also calibrated the PostureVel… Unfortunately, when I run the application, the subject jumps to a position that is indicated in the Joints and Drivers folder as you suggested. My question has to do with the Pelvis. I found how to adjust the R/L foot positioning further down the axes but cannot adjust my Pelvis position which causes my simulation to result in a subject standing with the spine arched backward rather than standing straight upwardly.


As i recall it, in the joint and drivers file there is a driver for the CoM positon. It drives the location of the CoM wrt to the global coordinate system in 0,0.

From your description
[li]the loading position is ok
[/li][li]when solving the model ends up bending backwards

I think the problem might be that you need to adjust the driver of the CoM, so that it do not drive to 0,0 but to a location between the feets. Note that CoM is alway measured wrt to global 0,0, so you might need to change the driver.

Best regards


I can’t solve a problem when I run kinematic. I import file .c3d, Change subject characteristics and force plate but I can’t run it show “kinematics.any(23) :kinematic analysis failed in time step 0”.

I attached files How do I do? Please let me know
Thank you

When the kinematics fails in the first time frame timestep 0 it can be multiple things e.g.
*Markers may not be placed correctly on body
*The initial position which is specified in the trial specific file does not reflect close enough the marker locations, try to alter the pelvis position and the joint angles so that the skeleton is closer to the recorded markers.


Please also see this link https://github.com/AnyBody/support/wiki/New-How-to-setup-your-own-MoCap-driven-Model

it is written about an older version of the mocap model but fundamentals on kinematics are still the same.

Best regards

please also see https://anyscript.org/tutorials/Making_things_move/lesson5.html

Please provide a few screenshots of the model

[li]when it has been loaded [/li][li]When it has tried to solve kinematics , then right click ModelView and click “force recreate view” then save the picture[/li][/ol]

please also provide the full error message