access is denied?

Hi,

I am new to AnyBody so I am still learning the software. I am using the GaitLowerExtremity model and I am simply trying to decrease the strength of one or some of the muscles in the legs to see how the body will compensate. After some time opening different “#include”, I managed to find the file (MusParSimpleAny) where I think I am able to change the strengths. The problem is that when I change the forces and click load, I receive an error message. It is not a message at the bottom saying I have too few constraints. It pops up saying “Access to (file directory that I’m in) is denied.” I do not understand why this is happening.

I tried to change something else within a different #include. When I try to change the 1’s and 0’s in the “BodyPartsSetup” and try to load it, an error message pops up saying access is denied for the “BodyPartsSetup”. Clicking ok, another error pops up asking if I want to "Set the Main file to “BodyPartsSetup”). Whether I click yes or no, another message pops up saying access to “BodyPartsSetup” was denied.

When I run the original file without editing anything, the error message comes up as well but the model still loads and I am able to see all the graphs and everything.

It seems to me that I am able to run the file as is but once I try to edit something, the errors pop up. If anyone has any information as to why this may be happening, please let me know.

Thanks,
Chris

Hi Chris,

that probably means that you are trying to modify the files in the installation folder. That is, of course, possible, if you talk to your administrators to allow you modifying Program Files content. But our recommendation would be to make a copy of this model somewhere in a working folder and simply connect to the repository.

As for the muscle strengths - you, again, should not modify the repository, since you may then hypothetically forget about this change. We suggest to use AnyOperationSetValue. Here is a small code example how this can be done:


  Main.Studies.InverseDynamicStudy.InitialConditions.PreOperation = {
    AnyOperationSetValue UpdatePsoasMajorStrength = 
    {
      AnyFloat value = 50;
      Source = &value;
      Target = &Main.Studies.HumanModel.BodyModel.Right.Leg.Mus.PsoasMajor1.Strength;
    };
  };

This operation should performed after the calibration sequence has been done and before the inverse dynamics analysis started. This way the values will be used and you do not need to change the original repository. So this is the proper way :slight_smile:

But, of course, you could just make a copy of the repository and modify it for your particular application.

Regards,
Pavel

Thank you so much Pavel. I simply copied all the AnyBody Files to a different place and it worked like a charm.

One more question…I found the code to change the lengths of bones, but it only has select bones to change the length. I am in the “TrialSpecificData” file and I am trying to change the length of different metatarsal bones. Is it possible to change the length of these bones in the GaitLowerExtremity file?

If it is not, can you tell me how I could figure this out myself without having to ask again?

Chris

Hi Chris,

Could you please let us know what repository and AMS you are using? We recommend to add this information to your signature - this way we can easier answer the question.

But from what I see - you use GaitLowerExtremity and that means that it is not the latest one. That, in turn, means that you cannot really change individual bone lengths. The option you have is to either change the dimensions of the foot hoping that all the segments will be scaled accordingly or construct a case-specific scaling law using morphing facilities.

On the other hand in AMMRv1.6 we have a foot model that contains 26 individual segments and each of them can be scaled on their own. But that may require some work too.

Please do not forget that the values that you change could be a subject of optimization - it means that they will be overwritten based on the optimization procedure. And if you would like it to be used - switch off the optimization.

Regards,
Pavel

Pavel,

Has AMMRv1.6 been released yet? I only see AMMR1.5. I downloaded that and it has the same segments as the one I was using before. I got it from this site: http://forge.anyscript.org/gf/project/ammr/frs/

Chris

Hi Chris,

AMMR 1.6 has been released this summer. It comes along with AMS 6.0 (and also requires this to run) which you can download from the www.anybodytech.com website when you log in to this site under Resources & Downloads -> Customer Downloads.

Best regards
Daniel