Error in kinematic analysis

Hello everyone,

seventeen subjects have been recorded by Xsens MVN Awinda inertial motion capture system with 17 wireless motion trackers and an update rate set to 60 Hz.
I am interested in estimating the Ground Reaction Force out of the BVH files. Here, the Xsens T-pose is in the beginning of every BVH file I am going to analyse. Thus, I was loading the inverse dynamic model, running the BVH_PreProcess and started to run the analysis. Some estimations succeeded, others resulted in errors. While analysing the BVH data of two different subjects I got errors during kinematic analysis. It is said that the constraints are above tolerance.
Please find one screenshot attached. I would be happy if you could assist me in how to proceed.

Many thanks and best regards,
Anja

Hi Anja,

Sorry for the slow response

Please try to avoid having the T-pose in the export since this may cause problems, when the model needs to go from t-pose to real position within one frame.

So either manually delete the frame in the bvh file or export the bvh again.

Hope it helps.

Best regards
Søren

Hi Soren,

Thanks for your reply. In my data the T-pose is captured within the first frame. Thus, I adjusted the StartFrame in trialspecificdata.any. I set the StartFrame to ‘2’, loaded the model, started the BVH_PreProcess and ran the analysis, but I still got an error in kinematic analysis. Then, I set the StartFrame to ‘7’ to be absolutely sure that there is no T-pose related data in the future analysis. However, again I got an error in kinematic analysis.

I am happy about any suggestions.

Thanks,
Anja

Hi Anja,

Can you attach the bvh file here, along with the subjects height and weight please so we can see what the error is?

Best Regards,
Christine

Hi Christine,

please find the bvh file with corresponding body dimensions in the below folder.

Thanks for your help,
Anja

VP2-002_kinematic_error.zip (4.6 MB)

Thanks this information helped! But this is kind of long process. Are there any shortcuts?
Regards,
Lewis

@Lewis-H Please create a new topic for this and state the specific question(s) you have.

Best Regards,
Christine

Hi Anja,

I am running only a portion of the trial right now and not obtaining any errors. What step did your model fail?

Best Regards,
Christine

Hi Christine,

when I am running the model with StartFrame setting to 7, the analysis fails in time step 12857.

Best regards,
Anja

Hi Anja,

Can you try this solution:

Go into BVHSettings.any and switch Rotation1PiFixOnOff = Off;
Rerun the BVH_Preprocess and then try again to RunAnalysis.

If it still doesn’t work, try switching Rotation2PiFixOnOff= Off; as well and rerun BVH PreProcess.

Please see this post for more information:

Best Regards,
Christine

Hi Anja,

I wanted to point your attention to this new post that may help fix the problem you are having (rather than using the work-around I gave previously):

Here is another document on how to update your old model:

Hope this helps, have a good weekend :slight_smile:

Best Regards,
Christine

Hi Christine,

both approaches you have recommended above worked, thanks a lot.
However, in the updated environment (approach 2, v.7.2.3, AMMR 2.2.3) the inverse dynamic analysis took about 6 days whereas the first approach (Rotation1PiFixOnOff = Off with AMMR 2.2.1) took only 1 day. For time reasons I would prefer approach 1. Can you tell me what Rotation1PiFixOnOff = Off causes? Do you think it is harmful for acurate data?

Thanks,
Anja

Hi Anja,

6 days sounds as a lot, how many frames do you have in the study?

Normally it can be a good idea to split long analysis into several to avoid having too many frames in the study.

The Rotation1PiFixOnOff is a setting that allows a filter to be enabled which will look at the rotation data in the BVH file and seek to remove jumps of 1PI. If this filter is off it will not be applied so if the data has these jumps the kinematic analysis may stop. If you do not see kinematic problems with the setting to be off you will usually be fine. If the filter is on it can sometime cause problems because the jumps in the angles may not always be exactly 1PI.

The new version 7.2.3 should resolve all issues with jumps in angles, we have not noticed a slow down but we will check it, is this something you see consistently also for models with fewer frames?

Best regards
Søren