How to Use C3D File to Drive the AnyBody

Hello, I`m Akira.I belong to Japanese college and new anybody user.
I post for first time.
I want to use C3D files of running that were captured with OptiTrack and analyzed with Arena.
I used “GaitFullBody” and I practiced “MotionAndParameterOptimization”,
but error " ‘PosInterpol’:Unresolved object" was indicated.
I read tutorial [Lesson 5: Using real data] but I didn’t understand.
Please tell me concrete method!!!

Hi Akira,

Welcome to the forum.

It sounds as you have a mismacth between the markernames used in the C3D file and the marker names used for the drivers.

If you look closer to the error message it might reveal which marker it can not find?

Please note that the marker drivers need to use the same names as you have in the C3D. The used names can be seen in the ModelSetup.any file where there is a secion for each of the markers.

If you are in doubt which names you have in the c3d file, load the file in a C3D viewer or create a empty anybody only containing the C3D object, both options will allow you to view the used names in the marker folder of the C3D. All names listed in the Modelsetup.any file needs to be present in the C3D file.

Hope this helps

Best regards

Thank you for message.
I loaded the C3Dfile in a C3D viewer and had a mismatch between the markernames used in the C3D file and the marker names used for the drivers.
Then I matched the marker names and practiced “MotionAndParameterOptimization”.
But same error was indicated.
Does the “AnyInputC3D” need ? If the “AnyInputC3D” need, where does the “AnyInputC3D” insert in GaitFullBody ?

Hi Akira,

Would you please upload your model in the ‘Debug’ section if possible?
It would be better for you to solve your problem.

Best regards,

Thank you for message.
I upload the file for “GaitFullBody”.
Please tell me the misstake.


You should say which version of AMS and AMMR that you are using whenever you want to debug your model.

Best regards,

AMS is ver5.1 and AMMR is ver1.4.
I beg your kindness.


I tried to debug your model.

But when I see your C3D file, what I’ve thought is that you have to modify the marker definitions in ‘ModelSetup.any’ file, for instance, marker name and its position with respect to its parent segments.

If this is really difficult for you, then I would suggest you to do your experiments again using VICON’s ‘Plug-in-gait marker’ set.

Right now, because there are so many changed code in your model, I’m sorry but I can’t debug your model.

Best regards,

thank you for your message.
I try to download AMMRv1.4 again and load the C3D file.
If the error appear, I ask some questions again.