error: Obj.Mch.Kin3


I was trying to upload my cd3 file into the gaitfullbody model and was faced with this particular error.

[SIZE=1]ERROR(OBJ.MCH.KIN3)[/SIZE] : [SIZE=1]C:/U…s/S…h/D…p/J…P/A…1/A…2/A…n/E…s/G…y/GaitFullBody.main.any[/SIZE] : [SIZE=1]MotionOptimization.InitialConditions[/SIZE] : Kinematic analysis failed in time step 0

[SIZE=2]I believe that the error arise due to the model initial position (since my model is one which the subject is lying down), but i’ve adjusted the model’s position and yet, im still unable to correct the error. Would really appreciate some help in identifying the root of the problem. Attached is my file. The file can be found under Application - Examples.[/SIZE]


The problem is that you removed the following lines in the CreateMarkerClass file:

    AnyParamFun &ref2 = Main.ModelSetup.C3DFileData.Points.Markers.MarkerName.PosInterpol;

That means all the upper body markers using this class are not driven correctly. I assume you did that because you get an error with T10 marker.
You can remove if you want the T10 marker but you must include again the above lines.

Also you change the name of the C3D file in the TrialSpecific file, you should do it instead in the ModelSetup file as it will be used in other places of the model.

Best regards, Sylvain.

Hi Sylvain,

Thanks for taking time to review my model. I guess i must have forgotten to add in the line after trying to fix the markers. However, i receive another error, and i am unable to solve it.

[SIZE=1]ERROR(SCR.PRS9)[/SIZE] : [SIZE=1]C:/U…s/S…h/D…p/J…P/A…1/A…2/A…n/E…s/G…y/ModelSetup.any[/SIZE] : Defined At : [SIZE=1]C:/U…s/S…h/D…p/J…P/A…1/A…2/Body/A…n/T…x/M…p/CreateMarkerClass.any[/SIZE] : ‘PosInterpol’ : Unresolved object

i think its something to do with my markers, but i am unable to resolve the error. I am rather new at this software, are you able to locate where my error is?

Also, i thought that i changed the C3D file in modelsetup file. Did i do it wrongly?

Appreciate your assistance, once again.


When i runned your model i got this error for the T10 marker. Is it still this one that causes the error?
The problem was that the T10 data was in a different folder inside the C3D file. This i don’t know why. But the result is that the path to the PosInterpol is wrong.
The quick fix is to remove the T10 marker in the ModelSetup. There should be enough markers left to run.

And about the C3D file name, sorry a wrote the inverse of what i wanted to say (i guess i wrote too fast). You did change it in ModelSetup. But i wanted to say it should be Changed in TrialSpecific instead.

Best regards, Sylvain.

Hi Sylvain,

I heeded your advice and removed the T10 marker, but im still unable to run the optimization function. It seems to me that the problem is that most of the errors of the constraints are above the tolerace level. I tried adjusting the trailspecificdata file but im still unable to reduce the error level. Would appreciate your advice on how i can solve this problem. I’d uploaded an updated copy of my model.

Thank you for your help in reviewing the model

Hi Sylvain,

I am wondering whether could the problem arise from the difference in the point of origin of the C3D file and anybody model? I tried adjusting the global reference point in the environment file but i still cannot reduce the error. Would appreciate your input.

Thank you


I found several problem in your model:

The marker LHEE have {0,0,0} coordinates during the whole trial, so it is permanently located at the origin and therefore is not usable. The LFHD and LBHD markers are also dropping. Those three will corrupt the kinematic, and you will have to remove them.
However that means the left ankle has not enough markers to be driven and you will have to fix the eversion with an extra driver.

The pelvis markers seems to be upside down. In your C3D file RASI and LASI seems to be on the back while RPSI and LPSI are on the front, this is the contrary of the markers defined on the model. So check the name and position of the markers for the real experiment and compare it to the name and position of the model markers. They have to match.

Try to have a better initial position. Lots of markers are far away, espacially on the trunk. Scale the model if necessary with the TrialSpecific variables.

Best regards, Sylvain.

Hi Sylvian,

Thank you for troubleshooting my model. Really appreciated your help. The initial condition is now fully updated. However, there is an error in the kinematic analysis. The error is as follows,

Failed to resolve kinematic constraints. Newton relaxation too small. (final kin. error = 5.144929E-006)
Constraint no. 49 above error tolerance 0.000001, error = 0.000001.
Constraint no. 56 above error tolerance 0.000001, error = 0.000001.
Constraint no. 63 above error tolerance 0.000001, error = 0.000001.
Constraint no. 70 above error tolerance 0.000001, error = 0.000005.
Constraint no. 71 above error tolerance 0.000001, error = 0.000001.
Constraint no. 72 above error tolerance 0.000001, error = 0.000001.
Constraint no. 91 above error tolerance 0.000001, error = 0.000001.
Constraint no. 93 above error tolerance 0.000001, error = 0.000001.
.62) …Kinematic analysis terminated
[SIZE=1]ERROR(OBJ.MCH.KIN3)[/SIZE] : [SIZE=1]C:/U…s/S…h/D…p/J…P/A…1/A…2/A…n/E…s/G…y/GaitFullBody.main.any[/SIZE] : [SIZE=1]MotionOptimization.Kinematics[/SIZE] : Kinematic analysis failed in time step 62

[SIZE=2]How do i locate the specific constrains at the specific time step? also, what can i do to successfully resolve the constraints?


Look at the model view. Often you can visualy detect what is going wrong. Look for strange positions of the shoulder and scapula (that is quite sensitive) or any other joint. Also look for more dropping markers, i din’t check the whole C3D file duration.
And for markers being too far from their matching pair. That can be improved with a better scaling and a better estimation of the marker location on the body.

Best regards, Sylvain.